Why do you not offer support or updates on Paper Tiger versions before 4.0?

Due to the cost and complexity of developing and maintaining the current version of The Paper Tiger software (or any software for that matter), Monticello only offers support (administrative or technical support) for previous versions of the product for twelve (12) months following a new major release.  As long as the older versions of the software are running properly and meeting the customer’s needs, customers are licensed to use the older versions and are not forced in any way to upgrade.  However, if the customer were to run into any compatibility issues with new Microsoft software releases (as frequently happens) or any other issues related to an unsupported version of The Paper Tiger, they will need to upgrade to the newest version of the software in order to receive support and be provided on-going software updates.  Currently, version 1.0, 2.0 and 3.0 are no longer supported.  In order for customers to avoid problems and get technical support, it is strongly recommended that they stay current by purchasing the newest version of the software.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request


Please sign in to leave a comment.
Powered by Zendesk